Forum

Information and discussion related to the Kognitio on Hadoop product
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

WARNING: Multiple MTU values found

by markc » Tue Nov 01, 2016 8:50 am

When starting up my kodoop cluster, I see this message in the output, but everything still seems to work - should I be concerned?

...
--> Configuring WX2 software.
Generation results:
WARNING: Multiple MTU values found for datalinks (65520 and 1500).

--> Initialising internal storage.
...
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: WARNING: Multiple MTU values found

by markc » Tue Nov 01, 2016 8:57 am

The message about multiple MTU values being found indicates that your system is using a set of links, and their MTU setting is inconsistent.

You can run the "kodoop server <clustername> info -F" command to get information on the links being used, including their MTU values, so you can see the discrepancy.

You can then either:
  • use the config file to specify the NETWORKS setting to only include the interfaces you want to use for internal communications by kodoop (e.g. just the 40Gb interfaces that support jumbo frames, but not any 1Gb interfaces that are used for external connections and do not use jumbo frames).
  • ensure the MTU value for all interfaces is the same, assuming this is what you really want (i.e. all the interfaces on each node really should be used for kodoop internal communication.
The reason the warning is generated is that it forces kodoop to use the smallest MTU specified for its links, and that can have a big impact on the performance of the message-passing component of the software. So although it will still work, you will see a significant performance hit for some operations which need to do a lot of data redistribution. Typically you want to ensure jumbo frames are enabled for links that are faster than 1Gb.
Reply with quote Top

Who is online

Users browsing this forum: No registered users and 1 guest

cron