Forum

Discussions specific to version 8.1
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

./linux-install-80100rel140121.sfx: Permission denied

by voolf » Fri Mar 14, 2014 11:53 am

Hi,

I have installed the 32 bit libraries and have the installer as executable on my CENTOS VM
I am running as root and continue to receive the following message (in both v or v8)

./linux-install-80100rel140121.sfx: Permission denied


I dont see anything logged in /var/log/messages

Any assistance would be appreciated.


Thanks
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Fri Mar 14, 2014 1:42 pm

Have you checked that the sfx file is executable? If you do "ls -ltr ./linux-install-80100rel140121.sfx", what do you see?
Reply with quote Top
Multiple Poster
Offline
User avatar
Posts: 5
Joined: Mon Mar 17, 2014 10:18 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by Alexander Pyramid » Mon Mar 17, 2014 10:43 am

We Made it an executable, see attached screen shot.
Any suggestions will be greatly appreciated.
Attachments
Executable.png
Executable.png (41.11 KiB) Viewed 119871 times
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 11:02 am

Can you tell me what you see from the command line you originally tried to run the program from (and in the same directory) if you run these commands:

whoami

groups

ls -ltr ./linux-install-80100rel140121.sfx

md5sum linux-install-80100rel140121.sfx
Reply with quote Top
Multiple Poster
Offline
User avatar
Posts: 5
Joined: Mon Mar 17, 2014 10:18 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by Alexander Pyramid » Mon Mar 17, 2014 12:01 pm

Hey
This is what i receive.
Attachments
Kognito.png
Kognito.png (36.38 KiB) Viewed 119869 times
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 12:11 pm

Do you have SELinux enabled?

If so, can you try disabling it. More information on SELinux is available here:

https://www.centos.org/docs/5/html/5.1/ ... sable.html
Reply with quote Top
Multiple Poster
Offline
User avatar
Posts: 5
Joined: Mon Mar 17, 2014 10:18 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by Alexander Pyramid » Mon Mar 17, 2014 1:31 pm

SeLinux is disabled still i get the same "permission denied".
Attachments
Selinux.png
Selinux.png (58.94 KiB) Viewed 119857 times
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 2:03 pm

Thanks - can you check that the filesystem the sfx file is on is not mounted noexec. If you indicate where the sfx file is, and then run the "mount" command to show how file systems are mounted, that should be sufficient.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 2:30 pm

I can reproduce the symptom you are seeing with the noexec mount:

root [root@centos-6 shm]# mount -o remount,noexec /dev/shm
root [root@centos-6 shm]# mount
/dev/mapper/vg_centos6-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,noexec)
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sr0 on /mnt type iso9660 (ro)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
root [root@centos-6 shm]# pwd
/dev/shm
root [root@centos-6 shm]# ls -ltr
total 49968
-rwxr-xr-x. 1 wxadmin wxadmin 51166104 Mar 17 14:01 linux-install-80100rel140121.sfx
root [root@centos-6 shm]# ./linux-install-80100rel140121.sfx
-bash: ./linux-install-80100rel140121.sfx: Permission denied
root [root@centos-6 shm]#
root [root@centos-6 shm]# mount -o remount,exec /dev/shm
root [root@centos-6 shm]# ./linux-install-80100rel140121.sfx
Kognitio WX2 Software Installer v8.01.00-rel140121
(c)Copyright Kognitio Ltd 2004-2014.

Installing the Kognitio WX2 database server software.
This installer will perform a 'stage 1' WX2 software install on this node,
allowing this node to link up with other nodes which are (or are going
to be) part of the same WX2 system.

This step must be performed on every node. Nodes will normally link up
automatically after this step is complete. Once all nodes have linked up, you
will need to perform a stage 2 install once on the entire WX2 system by
running the wxadmin command.

This installer will perform an interactive install for this node.
When this is complete, it will output instructions for performing
a non-interactive stage 1 install on the other nodes and for
performing the stage 2 install.

Type 'no' now and run this command with -h to see a full list of options

OK to continue (yes/no) ?no
Exiting.
root [root@centos-6 shm]#
Reply with quote Top
Multiple Poster
Offline
User avatar
Posts: 5
Joined: Mon Mar 17, 2014 10:18 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by Alexander Pyramid » Mon Mar 17, 2014 3:38 pm

Thanks for the reply.

I tried remounting, here is what we are seeing:

[root@localhost admin]# mount -o remount,exec /dev/shm
[root@localhost admin]# ./linux-install-80100rel140121.sfx
bash: ./linux-install-80100rel140121.sfx: Permission denied
[root@localhost admin]# mount
/dev/sda2 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
vmware-vmblock on /var/run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,default_permissions,allow_other)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 3:44 pm

Am I correct in thinking that the sfx file you are trying to execute is in /dev/shm in this case?
Reply with quote Top
Multiple Poster
Offline
User avatar
Posts: 5
Joined: Mon Mar 17, 2014 10:18 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by Alexander Pyramid » Mon Mar 17, 2014 4:00 pm

I didnt realize that it needs to reside in /dev/shm.

I tried running the file from there, but we are seeing the same error:

[root@localhost mnt]# mv linux-install-80100rel140121.sfx /dev/shm/
[root@localhost mnt]# cd /dev/shm
[root@localhost shm]# ls
linux-install-80100rel140121.sfx pulse-shm-1834928926 pulse-shm-3071405027
pulse-shm-1268803804 pulse-shm-190240859 pulse-shm-3433142467
pulse-shm-1307444915 pulse-shm-2188022020 pulse-shm-4154963977
pulse-shm-1399426598 pulse-shm-307132698 pulse-shm-74688822
[root@localhost shm]# ./linux-install-80100rel140121.sfx
bash: ./linux-install-80100rel140121.sfx: Permission denied
[root@localhost shm]# ls -la
total 50536
drwxrwxrwt 2 root root 280 Mar 17 09:01 .
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Mon Mar 17, 2014 4:12 pm

The file does not need to be in /dev/shm, it just needs to be in a filesystem which does not have noexec set - as you previously remounted /dev/shm to be executable, that would only have helped if the file was in /dev/shm.

This seems like some Linux issue to me, but I can't pinpoint what it is, so perhaps we can do more of a test. I am in /dev/shm as root on a Centos6.5 system, and created a test.sh file like this - can you try these same steps and let me know what happens:

first of all, show the permissions on my test.sh file - note it is not executable yet
[root@centos-6 shm]# ls -ltr
total 49972
-rwxr-xr-x. 1 wxadmin wxadmin 51166104 Mar 17 14:01 linux-install-80100rel140121.sfx
-rw-r--r--. 1 root root 35 Mar 17 16:06 test.sh

show the two line contents of the file
[root@centos-6 shm]# cat test.sh
#!/bin/sh
echo "I can be executed"

try to execute the file - this won't work as it does not have the executable bit set
[root@centos-6 shm]# ./test.sh
-bash: ./test.sh: Permission denied

mark the file as executable
[root@centos-6 shm]# chmod a+x test.sh

verify it is executable in terms of permission bits
[root@centos-6 shm]# ls -ltr test.sh
-rwxr-xr-x. 1 root root 35 Mar 17 16:06 test.sh

verify it runs now
[root@centos-6 shm]# ./test.sh
I can be executed

remount /dev/shm as noexec to stop the file running
[root@centos-6 shm]# mount -o remount,noexec /dev/shm

verify it no longer runs
[root@centos-6 shm]# ./test.sh
-bash: ./test.sh: Permission denied

remount /dev/shm as exec to allow the file to run again
[root@centos-6 shm]# mount -o remount,exec /dev/shm

verify it runs again
[root@centos-6 shm]# ./test.sh
I can be executed
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Mon Mar 17, 2014 8:14 pm

I have ran the suggested tests and the results received are as expected:

[root@localhost shm]# ./test.sh
bash: ./test.sh: Permission denied
[root@localhost shm]# chmod a+x test.sh \
> ^C
[root@localhost shm]# chmod a+x test.sh
[root@localhost shm]# ls -ltr test.sh \
> ^C
[root@localhost shm]# ls -ltr test.sh
-rwxr-xr-x 1 root root 36 Mar 17 13:07 test.sh
[root@localhost shm]# ./test.sh
I can be executed
[root@localhost shm]# mount -o remount,noexec /dev/shm
[root@localhost shm]# ./test.sh
bash: ./test.sh: Permission denied
[root@localhost shm]# mount -o remount,exec /dev/shm
[root@localhost shm]# ./test.sh
I can be executed
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Mon Mar 17, 2014 9:37 pm

I have run the suggested tests and they all result as expected
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 18, 2014 2:07 pm

Hi Marc,

Is there anything else we can check? We are still unable to run the installer.

Thanks
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Wed Mar 19, 2014 9:04 am

We're trying to think of all the mechanisms in Linux that can cause this sort of problem:

1) not having execute bit set - you've already shown this is not the problem.

2) having file system containing the sfx file marked as noexec - you've also shown this is not the problem.

3) not having 32 bit libraries in place - you indicate you've installed these, and anyway that should give an error like this:
[root@centos-6 shm]# ./linux-install-80100rel140121.sfx
./linux-install-80100rel140121.sfx: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

4) problems with SELinux. You've shown a config file indicating SELinux is disabled.

Could you also run the "sestatus" command as root and send us the output.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Wed Mar 19, 2014 9:36 am

In addition, the "." you see at the end of the file permissions for this file indicates an SELinux ACL. Can you do the following to find out what it is and send us the output:

getfattr -n security.selinux ./linux-install-80100rel140121.sfx

Can you also do "ls -aZ <dirname>" for the directory you have the sfx file in, and send the output from that.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Thu Mar 20, 2014 5:03 pm

[root@localhost admin]# sestatus
SELinux status: disabled
[root@localhost admin]# getfattr -n security.selinux ./linux-install-80100rel140121.sfx
./linux-install-80100rel140121.sfx: security.selinux: No such attribute
[root@localhost admin]# ls -aZ /home/admin
drwx------. admin admin unconfined_u:object_r:user_home_dir_t:s0 .
drwxr-xr-x. root root system_u:object_r:home_root_t:s0 ..
-rw-------. admin admin unconfined_u:object_r:user_home_t:s0 .bash_history
-rw-r--r--. admin admin unconfined_u:object_r:user_home_t:s0 .bash_logout
-rw-r--r--. admin admin unconfined_u:object_r:user_home_t:s0 .bash_profile
-rw-r--r--. admin admin unconfined_u:object_r:user_home_t:s0 .bashrc
drwxr-xr-x. admin admin unconfined_u:object_r:cache_home_t:s0 .cache
drwxr-xr-x. admin admin unconfined_u:object_r:config_home_t:s0 .config
drwx------. admin admin unconfined_u:object_r:dbus_home_t:s0 .dbus
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Desktop
-rw-r--r-- admin admin ? .dmrc
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Documents
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Downloads
-rw-------. admin admin unconfined_u:object_r:user_home_t:s0 .esd_auth
drwxr-xr-x. admin admin unconfined_u:object_r:user_fonts_cache_t:s0 .fontconfig
drwx------. admin admin unconfined_u:object_r:gconf_home_t:s0 .gconf
drwx------. admin admin unconfined_u:object_r:gconf_home_t:s0 .gconfd
drwxr-xr-x. admin admin unconfined_u:object_r:gnome_home_t:s0 .gnome2
drwx------. admin admin unconfined_u:object_r:user_home_t:s0 .gnome2_private
drwxrwxr-x. admin admin unconfined_u:object_r:user_home_t:s0 .gnote
drwx------. admin admin unconfined_u:object_r:gpg_secret_t:s0 .gnupg
drwxrwxr-x. admin admin unconfined_u:object_r:gstreamer_home_t:s0 .gstreamer-0.10
-rw-rw-r-- admin admin ? .gtk-bookmarks
drwx------. admin admin unconfined_u:object_r:user_home_t:s0 .gvfs
-rw-------. admin admin unconfined_u:object_r:iceauth_home_t:s0 .ICEauthority
-rwxrwxrwx admin admin ? linux-install-80100rel140121.sfx
drwxr-xr-x. admin admin unconfined_u:object_r:gconf_home_t:s0 .local
drwxr-xr-x. admin admin unconfined_u:object_r:mozilla_home_t:s0 .mozilla
drwxr-xr-x. admin admin unconfined_u:object_r:audio_home_t:s0 Music
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 .nautilus
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Pictures
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Public
drwx------. admin admin unconfined_u:object_r:pulseaudio_home_t:s0 .pulse
-rw-------. admin admin unconfined_u:object_r:pulseaudio_home_t:s0 .pulse-cookie
-rw------- admin admin ? .recently-used.xbel
drwx------. admin admin unconfined_u:object_r:ssh_home_t:s0 .ssh
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Templates
drwx------. admin admin unconfined_u:object_r:user_home_t:s0 .thumbnails
drwxr-xr-x. admin admin unconfined_u:object_r:user_home_t:s0 Videos
-rw-------. admin admin unconfined_u:object_r:user_home_t:s0 .viminfo
-rw------- admin admin ? .xsession-errors
-rw------- admin admin ? .xsession-errors.old
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Fri Mar 21, 2014 9:23 am

Thanks for that extra output - I can see there is no "." at the end of the attributes for the sfx file in /home/admin, indicating there is no SELinux ACL (although there was when the file was in /dev/shm as we can see from an earlier post in this thread).

I cannot think of any other reasons for a file being non-executable given that we've established:
1) the execute bit is set
2) the filesystem is not marked noexec
3) SELinux is definitely disabled, and there is no ACL for this file in /home/admin anyway.

We have been unable to reproduce the problem internally without one of the above issues being to blame.

Is there any other system you could try the SFX file on (possibly by downloading it again first)?

Alternatively, can you try using it in a cloud environment? http://www.kognitio.com/forums/viewtopic.php?f=6&t=46 has information on how you can try out a preconfigured environment in Amazon.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Fri Mar 21, 2014 9:44 am

To understand what might be the underlying problem here, could you also run the following commands:

first of all check the dependencies of the sfx file
ldd ./linux-install-80100rel140121.sfx

In my case I get:
[root@centos-6 tmp]# ldd ./linux-install-80100rel140121.sfx
linux-gate.so.1 => (0x00110000)
librt.so.1 => /lib/librt.so.1 (0x00111000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x0011a000)
libc.so.6 => /lib/libc.so.6 (0x007d0000)
libpthread.so.0 => /lib/libpthread.so.0 (0x0014a000)
/lib/ld-linux.so.2 (0x007a8000)
libfreebl3.so => /lib/libfreebl3.so (0x00165000)
libdl.so.2 => /lib/libdl.so.2 (0x001c5000)
[root@centos-6 tmp]#

for each file shown in the list, do "ls -ltr" for the file, and "file" for the file, and the same for any symbolic links. This is to determine whether any of the dependent libraries are inaccessible (e.g. NFS mount not working correctly)

So in my case, I would do this for the first entry in the ldd output, and the same for all subsequent entries:

[root@centos-6 tmp]# ls -ltr /lib/librt.so.1
lrwxrwxrwx. 1 root root 13 Dec 10 14:25 /lib/librt.so.1 -> librt-2.12.so
[root@centos-6 tmp]# file /lib/librt.so.1
/lib/librt.so.1: symbolic link to `librt-2.12.so'
[root@centos-6 tmp]# ls -ltr /lib/librt-2.12.so
-rwxr-xr-x. 1 root root 39676 Nov 21 21:13 /lib/librt-2.12.so
[root@centos-6 tmp]# file /lib/librt-2.12.so
/lib/librt-2.12.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, not stripped
[root@centos-6 tmp]#
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Fri Mar 21, 2014 10:34 am

I think we may be getting closer.

Here is the reply I get when entering the command:
[admin@localhost ~]$ ldd ./linux-install-80100rel140121.sfx
/usr/bin/ldd: line 163: /lib/ld-linux.so.2: is a directory
not a dynamic executable
[admin@localhost ~]$
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Fri Mar 21, 2014 11:43 am

OK, so it looks like attempts to install all 32-bit dependencies have not worked for some reason.

Can you start from scratch with a clean CentOS VM, then follow the instructions at http://www.kognitio.com/forums/viewtopic.php?f=2&t=138 which should install all the 32-bit components you need.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Mon Mar 24, 2014 9:05 pm

Installing a new VM seemed to help.
I am able to run the install, now I am facing this:

[root@localhost startup.T_2014-03-24_13:46:00_PDT]# more output
--> Cleaning up unwanted files/processes.
Cleaning old processes.
--> Clean up failed: falling back to pname method.
Erasing server working area.
--> Examining system components.
Using target {skey BOOTING-286573}
Detected:
WX2: Blocks 1, Nodes 1, Disks 0, Status Up.
Boot disks:
Boota: No disk!
Bootb: No disk!
WARNING: System is running without a hardware map file.
Unable to boot: No boot information found on system.


How do I configure the boot information?
Also, how do I find out the sysid to rerun the installer?

Thanks
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Tue Mar 25, 2014 8:45 am

Can you tar up the contents of /var/log/wx2 and attach to this thread so we can review them. I think I know what has happened here, but it is easiest to confirm by reviewing the logs.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 25, 2014 2:58 pm

Enclosed are the logs
Attachments
wx2.tar.gz
(22.28 KiB) Downloaded 1828 times
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Tue Mar 25, 2014 3:41 pm

Thanks for the logs.

Can you recall what you did after installing the software? The log files indicate you did something like "wxserver start" (although this might have been e.g. via the wxadmin command line tool), which is a command to restart the database after commissioning. However, the system was never commissioned, so nothing was written to disk, hence the errors you see.

http://www.kognitio.com/forums/Kognitio ... lation.pdf shows how to complete the installation, so following the instructions in there is probably the best way forward. If you have any other instructions, could you let me know where you got them from so I can review them, and amend them if they are e.g. on our website.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 25, 2014 4:39 pm

Thanks ,How do I uninstall and start from scratch ?
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 25, 2014 4:55 pm

I was able to reinstall, but can you advise on the fdisk syntax required to set up the kognitio Partition type hex ’60’, a.k.a. 0x60 ?


Thanks
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Tue Mar 25, 2014 5:14 pm

If you want to use raw partitions:

1) do "fdisk <device that you are creating them on>". I am most familiar with HP blades, where typically the device would be /dev/cciss/c0d0.

2) type "p" to see the existing partitions. Normally you'd have one or more Linux partitions, and some unpartitioned space - if there isn't unpartitioned space, you should probably stop now.

3) type "n" to create a new partition, then specify the partition number (I've only ever used primary partitions), then accept the default first cylinder and put in the last cyliner you want.

4) type "t" to specify a new type for a partition, provide the number for the partition you just created, then specify 60 as the type.

5) type "p" to confirm all is as expected, then "w" to write the changes out if you are happy with them.

6) reboot to apply the changes.


A simpler way if you aren't used to creating partitions is to use file-based storage instead, as referenced in the PDF mentioned in my previous comment. I'd recommend that approach.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 25, 2014 5:38 pm

Thanks,

I tried creating a file-based storage and now I am getting the following:

About to create a new database on system 'kognitio'.
WX2 system has: 1 node in 1 group.
Disk resources: 0.00G in 1 disk.
1 disk with size unknown.
(sizeto be defined at newsys/reconfigure).
System has 1 unique type of node.
System has 1 unique type of disk.
System RAM 1.87G, 1.87G for data processing.
1 CPU available for data processing.

Detected node classes:
full: 1 node

Detected Operating platforms:
Linux-2.6.32-431.5.1.el6.x86_64: 1 node

THIS WILL ERASE ALL EXISTING DATABASE DATA
About to erase database data and reset to defaults.
Enter to continue or ctrl-c to abort.
:
Logging startup to /var/log/wx2/logs-kognitio/startup.T_2014-03-25_10:40:33_PDT.
--> Cleaning up unwanted files/processes.
--> Clean up failed: falling back to pname method.
--> Examining system components.
--> Configuring WX2 software.
Generation results:
FATAL ERROR: WX2 disk resource size is unknown. Manually create or set [disks] size=
FATAL ERROR: 2 slabs - WX2 partitions are too small at -102416 logical sectors

WARNING: New boota is the same as new bootb.
Abandoning due to fatal errors.
Complete. Hit enter to continue.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Tue Mar 25, 2014 7:43 pm

I got a little bit further by specifying file size, but now I get the following:

bout to create a new database on system 'kognitio'.
WX2 system has: 1 node in 1 group.
Disk resources: 5.00G in 1 disk.
System has 1 unique type of node.
System has 1 unique type of disk.
System RAM 1.87G, 1.87G for data processing.
1 CPU available for data processing.

Detected node classes:
full: 1 node

Detected Operating platforms:
Linux-2.6.32-431.5.1.el6.x86_64: 1 node

THIS WILL ERASE ALL EXISTING DATABASE DATA
About to erase database data and reset to defaults.
Enter to continue or ctrl-c to abort.
:
Logging startup to /var/log/wx2/logs-kognitio/startup.T_2014-03-25_12:44:16_PDT.
--> Cleaning up unwanted files/processes.
--> Clean up failed: falling back to pname method.
--> Examining system components.
--> Configuring WX2 software.
Generation results:
WARNING: New boota is the same as new bootb.
--> Initialising disks.
Disk resource initialisation results:
FATAL ERROR: Error on WX-192.168.75.132: -2 - CANNOT FIND OR CREATE FILE /etc/kognitio AS user wxroot, group wxadmin!
.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Wed Mar 26, 2014 8:50 am

Looking at the output, I think the last line gives you the required information:

FATAL ERROR: Error on WX-192.168.75.132: -2 - CANNOT FIND OR CREATE FILE /etc/kognitio AS user wxroot, group wxadmin!

As the presentation discusses, the disk resources need to be writable by the Kognitio software - it shows the containing directory being owned by wxadmin, group wxadmin, permissions rwxrwxr-x, so if you ensure the containing directory for your disk resource is the same you should make more progress.

I should also add that the system you are trying to commission is VERY small at just one node with 2GB RAM and 5GB disk, so you won't be able to do very much with it once it is commissioned.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 13
Joined: Fri Mar 14, 2014 11:48 am

Re: ./linux-install-80100rel140121.sfx: Permission denied

by voolf » Wed Mar 26, 2014 7:40 pm

OK thanks for all the support, I have it up and running now

THIS WILL ERASE ALL EXISTING DATABASE DATA
About to erase database data and reset to defaults.
Enter to continue or ctrl-c to abort.
:
Logging startup to /var/log/wx2/logs-kognitio/startup.T_2014-03-26_10:36:23_PDT.
--> Cleaning up unwanted files/processes.
--> Clean up failed: falling back to pname method.
--> Examining system components.
--> Configuring WX2 software.
Generation results:
WARNING: New boota is the same as new bootb.
--> Initialising disks.
--> Initialising Database.
--> Creating newsys.sql new system script
--> Building new database
--> Logging build to /var/log/wx2/logs-kognitio/newsys.T_2014-03-26_10:37:32_PDT
--> Creating base system tables
--> Creating system groups
--> Populating base system tables
--> Setting privileges and statistics for base system tables
--> Set system default character set to CHARSET_LATIN1
--> Setting up virtual tables
--> Set up ODBC schema
--> Creating information tables
--> Creating import/export tables
--> Setting up logging and control tables
--> Creating system views
--> Creating external data browsing table/view
--> Creating system table comments
--> Set up IPE_ALLQUEUES
--> Loading default plugins
--> Finishing database configuration
--> Replicating newsys logs to all nodes.
Nothing to do or -n option given to wxsync.
Startup complete. SERVER IS NOW OPERATIONAL.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: ./linux-install-80100rel140121.sfx: Permission denied

by markc » Thu Mar 27, 2014 8:39 am

That's great news, thanks for letting us know.
Reply with quote Top

Who is online

Users browsing this forum: No registered users and 1 guest

cron