Forum

Discussions specific to version 8.1
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Cannot commission with technology preview on RHEL/Centos

by markc » Tue Jul 30, 2013 4:49 pm

I have installed the software on a RHEL system, but cannot get it to commission. Are there any tweaks I need to apply?
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: Cannot commission with technology preview

by markc » Tue Jul 30, 2013 4:54 pm

This is probably because RHEL and Centos enable Address Space Layout Randomization by default. The technology preview release needs to map shared memory areas for fast system restarts to a specific address, because they contain pointers. This restriction will be removed in future, but for now you will need to disable the ASLR feature as follows:

1) run the following on every node as root:

echo 0 > /proc/sys/kernel/randomize_va_space

2) restart all the smds, typically by logging in as wxadmin on one node and running "wxserver smd all restart".

3) proceed with the task you were attempting before - in this instance, commissioning the system.

The above will interactively disable ASLR - to make this change persist, add the following entry to /etc/sysctl.conf on every node:

kernel.randomize_va_space=0
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: Cannot commission with technology preview on RHEL/Centos

by markc » Tue Oct 15, 2013 1:40 pm

Note that version 8.1, due for release on 18th October, will work out of the box on RHEL and Centos - the instructions above are only required for the technology preview software.
Reply with quote Top

Who is online

Users browsing this forum: No registered users and 1 guest

cron