Forum

General discussion on using the Kognitio Analytical Platform.
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

wxtop not showing mpid and process name any more

by markc » Fri Sep 02, 2016 2:36 pm

I used to run wxtop and see useful information in the PROCESS column - each process would be listed as e.g.

WXDB(0): Ramstore

...but for some reason the same command now shows just the following for the PROCESS column:

wxdb

What has happened?

I have a 20 node system with version 8.1.0rel160415 on top of RHEL 6.5.
Reply with quote Top
Contributor
Offline
User avatar
Posts: 386
Joined: Thu May 23, 2013 4:48 pm

Re: wxtop not showing mpid and process name any more

by markc » Fri Sep 02, 2016 2:39 pm

The problem is that Kognitio up to version 8.1 stores information under /var/tmp on startup, but current RHEL distributions default to wiping the contents of that directory periodically (e.g. see (http://superuser.com/a/168127).

So once your system has been running for 30 days, you will see this problem. You can change your setup to prevent these contents being wiped, which would prevent the problem from happening in future (clearly you'd need to restart the DB software as well if the problem is already exhibiting on a system).

The Kognitio On Hadoop version does not have this issue, and release 8.2 should address the problem for new installations as well.
Reply with quote Top

Who is online

Users browsing this forum: No registered users and 2 guests

cron